Cover-Letter/flake.nix
Tigor Hutasuhut ee38273059
Some checks failed
build resume / build (push) Failing after 5s
initial commit
2024-07-02 16:09:45 +07:00

26 lines
548 B
Nix

{
inputs = {
nixpkgs.url = "nixpkgs/nixos-unstable";
utils.url = "github:numtide/flake-utils";
};
outputs = { self, nixpkgs, utils, ... }:
utils.lib.eachDefaultSystem (system:
let
pkgs = import nixpkgs { inherit system; };
in
{
devShells.default = pkgs.mkShell {
buildInputs = [
pkgs.typst
pkgs.typstyle
pkgs.typst-live
];
shellHook = ''
echo `${pkgs.typst}/bin/typst --version`
'';
};
});
}